Open CL not working with AMD pro drivers/ cards

  • 3 Replies

0 Members and 1 Guest are viewing this topic.

Offline Dievolve

  • *
  • Fractal Freshman
  • *
  • Posts: 8
« on: June 30, 2019, 05:48:39 PM »
Hello, greetings fellow fractal enthusiasts!  I just wanted to report that open CL seems not to work with AMD pro cards. Anyone else having this issue?
I tried this with windows 10 Mandelbulber 2.17 and 2.18. Also was running into the open CL compilation error on mac.  I do have some rudimentary coding experience and workstations with macos, windows and linux for testing if I can help, I will try. I am very thankful for this program and community. Please let me know if you have any workarounds or should I try to get a nvidia GPU?  Radeon RX 580 seems to work fine.  Radeon WX W7100 and firepro W8100 will not work with pro drivers.  I had them recognized with gaming driver, but still got a "no opencl devices" error on startup.  I could select them manually that way and openCL would work. Hoping to use them with the pro drivers so Blender works with pro-render.  Looking forward to stereo open CL and would be extremely interested in immersive/ 360 capture as well.  :peace:


Offline buddhi

  • *
  • Fractal Feline
  • **
  • Posts: 157
    • Mandelbulber GitHub repository
« Reply #1 on: June 30, 2019, 06:27:49 PM »
Can you summarize on which system with which GPU it works or not works? It is hard to get it from your post.
You wrote about compiler errors. What errors are do you get?

Offline Dievolve

  • *
  • Fractal Freshman
  • *
  • Posts: 8
« Reply #2 on: July 12, 2019, 12:27:01 AM »
  Hello, thanks for the response.  It has been too busy for me to respond quickly.  Much respect for you and this project. One of my favorite expressive tools for exploring the great mystery! Thanks for your work on this project. I aspire to someday have the coding skills to build software this cool.   
The good news is I managed to get pro cards working with the gaming drivers.
So for most tests I have been using windows 10. workstations are as follows:
dual xeon 2670v1 running windows 10 tested with radeon rx 580 and 19.10.18 pro enterprise driver. I installed 19.7.1 (newest gaming driver) and voila, it recognizes the rx 580.  WX7100 also will work with the gaming drivers.
tested with versions Mandelbulber 2.16-2.18. Error: no open cl devices happens with enterprise drivers installed with the following GPUs Radeon RX 580 plus the Firepro W8100 and WX7100 all are having issue with pro drivers.
Second build is a threadripper workstation, tested with all the above plus a new Radeon VII.
  I just installed gaming drivers 19.5.2 and it sees the Radeon VII as a GFX 906 (same with 19.5.2).  I am thrilled with the performance but puzzled by the reference. 8K render i am working on now takes 6 seconds with full open cl vs 4 minutes without open cl.  Mainly just a heads up that the enterprise drivers (I like to use for blender and prorender) are not working. My pipeline includes exporting 3D models, cleaning them up and working in Blender (2.8 or 2.79) to animate them so prorender feature (only on pro driver) would be nice if it worked smoothly. I even tried reinstalling 19Q2 pro driver and the same no open cl error occurs.

Third build is an i7 (4700K) build. same issues except the iGPU can handle basic open cl so no error on start.

MacOs is a separate issue.   Basically rendering fails with open cl error.

Thank you!

Offline R-TEAM

  • *
  • Fractal Friend
  • **
  • Posts: 12
« Reply #3 on: October 08, 2019, 02:01:46 PM »
Works fine here with Win10 - AMD FirePro w8100 Pro-driver 19.Q3.1
miss only the option for double precision .... :)

Open CL working like a beauty

Started by mfg on Mandelbulber

36 Replies
Last post February 02, 2020, 03:06:38 AM
by mfg
version 2.17: open cl working gtx 1080 with hitches (linux)

Started by JerryS on Mandelbulber

1 Replies
Last post April 27, 2019, 06:03:42 AM
by mclarekin
OpenCL two cards configured, it works only one

Started by jeyjey on Mandelbulber

5 Replies
Last post October 20, 2018, 01:33:34 AM
by mancoast
Issue with volumetric lighting on AMD cards?

Started by Opiumis on Mandelbulber

11 Replies
Last post May 20, 2020, 06:02:34 AM
by lycium
mandelbulb can't open animation file (windows)

Started by mponny on Mandelbulb3d

5 Replies
Last post November 17, 2018, 11:34:00 PM
by Sabine62