feature request - make the gamepad support required

  • 5 Replies
  • 248 Views

0 Members and 1 Guest are viewing this topic.

Offline JerryS

  • *
  • Fractal Freshman
  • *
  • Posts: 3
« on: June 06, 2018, 03:55:59 AM »
Hi, I would like the joypad support to be a required part of mandelbulber instead of a compile time option. This, hopefully would get smarter eyes than mine to look at what ubuntu packages are required to enable this support. I have investigated to the end of my ability, please help. Thank you all for the program Here's a picture I made with it.

Offline buddhi

  • *
  • Fractal Phenom
  • ****
  • Posts: 53
    • Mandelbulber GitHub repository
« Reply #1 on: June 09, 2018, 08:55:05 AM »
It is an option because qtgamepad is very new feature in Qt. It is available in Linux Debian since version 5.10. Earlier it was just an experimental library.
I Mandelbulber it is not final implementation.
This is the reason why it is an option.
To use it you need to install libqt5gamepad5 and libqt5gamepad5-dev
When you run qmake it will detect is this this library is in the system and use it automatically.

Offline JerryS

  • *
  • Fractal Freshman
  • *
  • Posts: 3
« Reply #2 on: June 10, 2018, 01:50:36 AM »
With respect sir, those packages do not appear to be in ubuntu 18.04 mate.
Code: [Select]
jj@parker:~/Desktop$ sudo apt install libqt5gamepad5-dev libqt5gamepad5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libqt5gamepad5-dev
E: Unable to locate package libqt5gamepad5
should I try to contact the maintainer for qt in ubuntu?

Offline mclarekin

  • *
  • Fractal Furball
  • ***
  • Posts: 206
« Reply #3 on: June 10, 2018, 02:51:00 AM »
so you need to get them before installing.

Please  continue to document any steps or problems, as I also would like to try the gamepad in Ubuntu 18.04

Offline buddhi

  • *
  • Fractal Phenom
  • ****
  • Posts: 53
    • Mandelbulber GitHub repository
« Reply #4 on: June 10, 2018, 05:16:49 PM »
In Ubuntu there is still Qt 5.9 which doesn't have QtGamepad module. Probably it will come with Qt 5.10 in Ubuntu. If you want to play with it try to use Debian Buster (testing) which already has Qt 5.10.

Offline JerryS

  • *
  • Fractal Freshman
  • *
  • Posts: 3
« Reply #5 on: June 13, 2018, 04:11:22 AM »
OOOOHh, that's what's going on, thanks Buddhi.