(Problem) Pages stuck loading

  • 1 Replies
  • 200 Views

0 Members and 1 Guest are viewing this topic.

Offline pauldelbrot

  • *
  • 3f
  • ******
  • Posts: 1924
« on: January 13, 2018, 09:52:32 PM »
The CSS-randomly-not-loading problem persists (and seems to affect also sometimes images and other things on a page), and uploads to the gallery are still plagued by intermittent spurious 400 errors. And now no page on the site will finish loading. Even if everything seems to be loaded the browser keeps spinning and says "Transferring data from fractalforums.org", or sometimes instead from "cdnjs.cloudflare.com".

Incidentally, math doesn't render correctly if scripts from the latter domain aren't whitelisted, which a) was not the case at the old site and b) presents a security risk to users, since so far as I can tell cdnjs.cloudflare.com is not specific to FractalForums. So there could be a malicious site somewhere out there that has malicious scripts that it hosts at the same cloud storage company, and there's no way to allow the FractalForum math script without also allowing the (hypothetical) malicious site's (hypothetical) malicious scripts, which will then zap you if you ever happen to stumble across the (hypothetical) malicious site.

Users who whitelist scripts are much, much more secure if sites keep all of their user-functionality-providing scripts in-house and avoid storing them at generic cloud-provider domains. (It's the opposite with useless-to-the-user scripts like tracking and advertising ones, of course: third party hosting of those makes it easy to block them without unwanted side effects to protect one's privacy and avoid being hacked by someone using the ad network to disseminate malvertising.)


Linkback: https://fractalforums.org/forum-help-and-support/31/pages-stuck-loading/717/

Offline Anon

  • *
  • Fractal Fluff
  • *****
  • Posts: 354
« Reply #1 on: January 13, 2018, 10:51:00 PM »
Do you see the same behavior on different browsers?

It would be helpful to attach screenshots for visual issues.

I use uBlock Origin and uMatrix on Firefox and Chrome.
See attached image for my uMatrix settings.

Latex style math syntax uses cdn.mathjax.org to render correctly on this site.
Search the site for more discussions about the Mathjax implementation.

My only persistent (intermittent) issue is session timeout messages when posting.
I post again and the action processes normally.

I have not seen many of the issues that you are describing.
I hope others will offer input to help narrow down these problems.


xx
"Time Span"

Started by cricke49 on Fractal Image Gallery

0 Replies
510 Views
Last post August 02, 2018, 07:05:21 AM
by cricke49
xx
OpenGL font rendering

Started by sjhalayka on Programming

2 Replies
127 Views
Last post April 20, 2020, 05:00:47 PM
by sjhalayka
clip
Error Message Loading JIT Formulas

Started by fractalrock on Mandelbulb3d

1 Replies
110 Views
Last post August 02, 2019, 07:27:34 PM
by fractalrock
xx
Clicking on links to pages here

Started by FractalDave on Forum Help And Support

6 Replies
242 Views
Last post December 20, 2018, 02:02:05 AM
by FractalDave
xx
Birdie Style

Started by gannjondal on Fractal Image Gallery

1 Replies
554 Views
Last post May 08, 2018, 02:39:37 PM
by who8mypnuts