certain images refuses to upload

  • 15 Replies
  • 1262 Views

0 Members and 1 Guest are viewing this topic.

Offline hgjf2

  • *
  • Fractal Fruit Salad
  • *****
  • Posts: 75
« on: January 12, 2019, 06:37:52 PM »
Today I looked that certain images don't want to be uploaded here and the buffer stuck to 0%. Please help! >:(

Offline RedshiftRider

  • *
  • Global Moderator
  • *******
  • Dendritic Entity
  • Posts: 174
  • Dagomar Schreuder
    • Youtube
« Reply #1 on: January 12, 2019, 07:27:24 PM »
Could you give a bit more details so that it is easier to figure what is going on. Can you give us the file size, image dimensions and browser you used?

Also, there was no need to report your post for it.

Edit: I see you uploaded them via the post attachements. It is better to upload images to the gallery.

Offline hgjf2

  • *
  • Fractal Fruit Salad
  • *****
  • Posts: 75
« Reply #2 on: January 12, 2019, 09:24:22 PM »
I had trouble with an image JPG with 7Kb size and just after a resize with WINDOWS PAINT, isn't uploadable on FRACTALFORUMS due buffer stuck at 0%. This image is a fractal example for a comparison founded on a Google search
This bug report is just an ask as suggestion for to improve FRACTALFORUMS.
I uses GOOGLE CHROME.

Offline 3DickUlus

  • *
  • 3f
  • ******
  • Posts: 1225
    • Digilantism
« Reply #3 on: January 13, 2019, 05:29:48 AM »
as attachement or posting in the gallery ???
Resistance is fertile... you will be illuminated!

https://en.wikibooks.org/wiki/Fractals/fragmentarium

Offline hgjf2

  • *
  • Fractal Fruit Salad
  • *****
  • Posts: 75
« Reply #4 on: January 13, 2019, 07:53:32 AM »
as attachement

Offline 3DickUlus

  • *
  • 3f
  • ******
  • Posts: 1225
    • Digilantism
« Reply #5 on: January 13, 2019, 08:25:09 AM »
can you post a link to the exact image that would not upload?

Offline hgjf2

  • *
  • Fractal Fruit Salad
  • *****
  • Posts: 75
« Reply #6 on: January 13, 2019, 11:27:43 AM »
This image unuploadable on FRACTALFORUMS is on site: "https://softologyblog.wordpress.com/2011/07/27/more-new-mandelbulb-variations/"
image has code "https://i2.wp.com/farm7.static.flickr.com/6146/5952795103_b4e1184f58.jpg".
The image might to be used for a comparison at a my comment about fractals in nature
« Last Edit: January 13, 2019, 11:39:43 AM by hgjf2 »

Offline RedshiftRider

  • *
  • Global Moderator
  • *******
  • Dendritic Entity
  • Posts: 174
  • Dagomar Schreuder
    • Youtube
« Reply #7 on: January 13, 2019, 11:52:42 AM »
There are two things that kind of bother me:

1. It is possible embed the images by using the image tag:
Code: [Select]
[img]Image URL[/img]It is easier to do than to download them and then add them by uploading them again.

2. You can't just download images from other sites and upload them here unless you provide a source.
« Last Edit: January 13, 2019, 01:31:27 PM by RedshiftRider »

Offline 3DickUlus

  • *
  • 3f
  • ******
  • Posts: 1225
    • Digilantism
« Reply #8 on: January 13, 2019, 05:05:55 PM »
Well, softology is a member here, and you're right RedshiftRider, grabbing images from other sites and uploading or attaching is not good, but linking with references is better, and better than that is permission from the owner.


Rule 404 – Power 2 Juliabulb from https://softologyblog.wordpress.com/2011/07/27/more-new-mandelbulb-variations/
Code: [Select]
[img]https://i2.wp.com/farm7.static.flickr.com/6146/5952795103_b4e1184f58.jpg[/img]
@hgjf2 how are you attaching? as url? that won't work (or at least it shouldn't) use [img] tags for remote files!

Offline Tas_mania

  • *
  • Fractal Friar
  • *
  • Posts: 111
    • West Tamar Talk
« Reply #9 on: March 05, 2019, 05:41:11 AM »
I'm sure this is the problem. Images upload OK, but are then given a forum url that is incredibly long - over 8,000 characters.That exceeds an internal forum limit so the images cannot be included in a post.
In other words fractal forums issues a web address to an image that exceeds the character limit that fractal forums uses.It's a server side issue.

Offline 3DickUlus

  • *
  • 3f
  • ******
  • Posts: 1225
    • Digilantism
« Reply #10 on: March 05, 2019, 06:07:34 AM »
I need an example, I have had my head in the code and the logs and attached many images. So far I have never encountered a case where the forum generates anything other than a "normal" url. I would think that the issue is from putting a web url in place of a local file name when trying to "upload" and image, that simply won't work!
Files from my local machine upload as they should, attachments load and display as they should, img tags display as they should, so a real working example reproducing what you say happens is required.

Don't blame the forum servers or code without proof and maybe confirmation or verification from at least 1 other user.
The image @hgjf2 refers to is shown in my last post with no problems so...   ::)

(recall he downloaded the image and resized it with WINDOWS PAINT)  (and maybe saved a BMP file with JPG extension and tried to upload that ??? )

Offline Tas_mania

  • *
  • Fractal Friar
  • *
  • Posts: 111
    • West Tamar Talk
« Reply #11 on: March 05, 2019, 10:26:14 AM »
I tried to upload an image to the Fractal Forums test area. I took a screengrab of the error message I received and uploaded it to my blog site and then linked it here :(A problem with forums is that admins have different 'roles' with varying 'permissions' etc. That could explain why it's not happening for the admins.



Offline RedshiftRider

  • *
  • Global Moderator
  • *******
  • Dendritic Entity
  • Posts: 174
  • Dagomar Schreuder
    • Youtube
« Reply #12 on: March 05, 2019, 12:18:27 PM »
Sounds reasonable.

Do you still have the link to the image? Could you paste it into a txt file and attach it or paste it into pastebin and share the link to that?

Offline Tas_mania

  • *
  • Fractal Friar
  • *
  • Posts: 111
    • West Tamar Talk
« Reply #13 on: March 05, 2019, 11:18:32 PM »
I just uploaded the images to the test area and all is good.
https://fractalforums.org/testing-area/24/testing-image-upload/2667
It's only when I drag and drop images that I get the error message.

I wanted to have the images with text above and below but they are placed below any text.

Also its not possible for a user to delete their own posts. 'Modifying' a post is good but a user should be able to delete a post.

Offline 3DickUlus

  • *
  • 3f
  • ******
  • Posts: 1225
    • Digilantism
« Reply #14 on: March 06, 2019, 06:24:33 AM »
hmm... the drag'n'drop thing is flakey, I don't like it and don't use it, fixing it is beyond the effort I have time for, (sorry if I sound curt) it was installed before I started admining, in theory you should be able to drop multiple files on it and have them upload but I don't think that has ever worked, I would like to remove that mod completely  >:(

I've never seen the 80000 characters error before though  ??? is there any problem with the "Browse" button below the drag'n'drop area? on linux that button accepts drag'n'dropped files but only on pages that have only the button for attaching files.

thank you for nailing that btw  :thumbs: I will have a look if I have time but it may just be to uninstall it  :-\

edit: oh, that limit has nothing todo with a url generated by the server it is the message length limit, that means that the goofy bit of java script that is handling the drag'n'drops is trying to read the image into the message text area !


xx
My First Fractal Upload

Started by Tas_mania on Fractal Image Gallery

0 Replies
298 Views
Last post September 24, 2017, 01:14:33 AM
by Tas_mania
xx
Something screwed up a gallery upload

Started by pauldelbrot on Forum Help And Support

3 Replies
215 Views
Last post September 14, 2018, 08:51:03 AM
by 3DickUlus
xx
test-upload please ignore

Started by Sabine62 on Fractal Image Gallery

4 Replies
308 Views
Last post September 24, 2017, 02:13:16 PM
by Sabine62
xx
test-upload please ignore

Started by Sabine62 on Fractal Image Gallery

2 Replies
278 Views
Last post September 24, 2017, 02:11:32 PM
by Sabine62
clip
Video upload link broken

Started by Paigan0 on Forum Help And Support

2 Replies
152 Views
Last post March 23, 2018, 09:34:30 PM
by Paigan0