(Problem) animated gifs not working as attachments

  • 3 Replies
  • 284 Views

0 Members and 1 Guest are viewing this topic.

Offline claude

  • *
  • 3f
  • ******
  • Posts: 1255
    • mathr.co.uk
« on: September 22, 2017, 01:30:46 PM »
here is an animated gif image: https://mathr.co.uk/tmp/epicycles.gif
I attach it to this post too
the preview thumbnail is a jpeg, so no animation
clicking the preview to make it bigger gives a gif in a lightbox, but only the first frame (as far as I can tell)

I'll test if the gallery supports animated gifs very shortly and report back.
EDIT: seems to work (or at least it used to): https://fractalforums.org/index.php?action=gallery;sa=view;id=7

Linkback: https://fractalforums.org/discuss-fractalforums/5/animated-gifs-not-working-as-attachments/354/

Offline Fraktalist

  • *
  • Administrator
  • *******
  • Strange Attractor
  • Posts: 1142
« Reply #1 on: September 22, 2017, 02:08:16 PM »
hm, confirmed. attached images are currently re-encoded for the large thumbnail that shows directly under each posts. (though I tested deactivating this just now and it still doesn't play - os set back to normal again)

but it should at least play properly when opening in the lightbox.
I'm doing another backup of everything and then will uninstall the lightbox mod (which has no simple on/off switch). and the test again if it works.

Offline Fraktalist

  • *
  • Administrator
  • *******
  • Strange Attractor
  • Posts: 1142
« Reply #2 on: September 22, 2017, 02:45:53 PM »
ok, we had ticked this setting:
"Re-encode potentially dangerous image attachments
Selecting this option will enable trying to re-encode the uploaded image attachments. Image re-encoding offers better security. Note however that image re-encoding also renders all animated images static. "


I deactivated it for a test.
now I get "Your attachment has failed security checks and cannot be uploaded. Please consult the forum administrator."
awesome. Let me contact myself. Problem is, I have no clue what to do about it.

Offline Fraktalist

  • *
  • Administrator
  • *******
  • Strange Attractor
  • Posts: 1142
« Reply #3 on: September 22, 2017, 02:55:24 PM »
okay, common smf problem.

do you perhaps have xml-data in the header of the file? I understand little of this, but it's mentioned here as a potential source of the problem:
https://www.simplemachines.org/community/index.php?topic=418692.msg2957835#msg2957835

else, we will just have to live with this.

I also test-uninstalled fancybox our lightbox mod. now you can't even click on the image anymore. and if you click the attachment link it opens the download dialog - no way to just have a look at it.

I don't know what else to try to solve this - any input would be appreciated.


xx
"Time Span"

Started by cricke49 on Fractal Image Gallery

0 Replies
338 Views
Last post August 02, 2018, 07:05:21 AM
by cricke49
xx
Is there any fractal software that can incorporate GIFs with fractals?

Started by abbaddon1001 on Fractal Programs Discussion, Help, & Support

0 Replies
141 Views
Last post May 07, 2018, 05:26:22 PM
by abbaddon1001
clip
3D Kleinian animated gif

Started by JosLeys on UltraFractal

3 Replies
323 Views
Last post November 20, 2017, 12:28:10 PM
by JosLeys
clip
Can Ultrafractal orbit trap animated images?

Started by abbaddon1001 on UltraFractal

0 Replies
282 Views
Last post May 22, 2018, 10:32:35 PM
by abbaddon1001
xx
Birdie Style

Started by gannjondal on Fractal Image Gallery

1 Replies
407 Views
Last post May 08, 2018, 02:39:37 PM
by who8mypnuts